Repeat picking in topaz picker

Hi, all! I met a question about Topaz picking. I used all micrographs and particles of high quality 2D classes to train the model. And then I used the “Topaz Extract” job and “Particle extract” job. I found that there were many repeat picking in the micrographs. I thought maybe something was wrong. All parameters were default in above three jobs. The “Expected number of particles” was 100. Can anyone help me?

Hi @Yuqi,

You need to alter the “radius of extracted regions” parameter in Topaz Extract.

This is rather confusingly named but basically corresponds to the minimal allowed distance between picks in downsampled pixels.

If you used a downsampling factor of 4 in the preceding Topaz Train job, and assuming a original pixel size of 1Å, then the default of 7 for this parameter will correspond to a minimum inter particle distance of 28Å - leading to the behavior you are seeing.

I would recommend adjusting this value to correspond to ~0.5-1 particle diameter, depending on the geometry of your particle.


1 Like

I also end up running a “remove duplicate particles” between a Topaz extract job and the particle extraction just to be safe. Typically if I’ve set the “radius” parameter correctly during Topaz extract there won’t be too many duplicates, but I also like it as a second sanity check.