Remove duplicates job is failing on missing inputs (v3.3.2+220824)


I have been processing this data for several months and decided to go back to a particular stack to do some quantification. I tried to run a remove duplicates job and received the following error:

Traceback (most recent call last):
  File "cryosparc_master/cryosparc_compute/", line 52, in
  File "/admin/opt/common/cryosparc3.1/cryosparc_master/cryosparc_compute/jobs/", line 838, in check_default_inputs
    assert False, 'Non-optional inputs from the following input groups and their slots are not connected: ' + missing_inputs + '. Please connect all required inputs.'
AssertionError: Non-optional inputs from the following input groups and their slots are not connected: particles.location. Please connect all required inputs.

I tried this both with and without micrographs provided as inputs (providing pixel size instead). Thinking it may have been the particular particle stack, I went to another stack and tried the same thing to no avail. Am I missing something here?

Best regards,

As another sanity check, I cloned and re-ran the local refinement, fed those outputs into remove duplicates, and it fails again.

Please can you post a screenshot of the expanded inputs from the Inputs and Parameters tab?

1 Like

Here you go, I see the location is missing - how can I remedy this?

What type of job was J3361? Maybe if you trace back, you can see where the particle location disappeared, and then replace it here using the low level results interface?

1 Like

J3361 is a Remove Duplicates job. I’m looking for particle location meta data in the low level jobs and only Extract or Particle Sets jobs, as far as I can tell, contain this link. Strangely, Import jobs do not. This particle stack was imported from a Relion Polish job. Also, I can successfully run a Local Refinement on this stack prior to the Remove Duplicates job. I’m a little stumped.

Hi Navid, if you import particles from relion without associating with a set of micrographs, the locations will be lost. Maybe that is what happened?

It is not surprising that you can run Local Refinement on these particles - the particle locations are not needed for this, only the relative offsets.

1 Like

It turns out this was the result of some corrupted data. Re-ran the entire branch and recovered.