Pyem update problem

I am trying to update pyem and think I am doing something wrong.

When I run csparc2star, I get the following error. I am using v3.1.0.

Traceback (most recent call last):
File “/home/lab/software/pyem/csparc2star.py”, line 28, in
from pyem import metadata
File “/home/lab/software/pyem/pyem/init.py”, line 3, in
from . import metadata
File “/home/lab/software/pyem/pyem/metadata.py”, line 415
ptdf = util.dataframe_from_records_mapped(pt, {**general, **micrograph})
^
SyntaxError: invalid syntax

pyem requires Python 3, please follow the installation instructions on the github wiki.

Thanks, Daniel. I am using a machine that I did not set up and pyem works differently than how I was previously used to. On this machine, I do not have to enter the activate commands to run, but on my own machine, I do. I was told there may be some important symlinks in usr/bin or usr/local/bin, but I didn’t find any. I was a bit worried about breaking something by installing over the old installation that has some hidden features. I’ve updated on a different machine without problem, but that was setup differently.
I do see I need to get python 3, so I may have to bite the bullet and just go for it and hope nothing goes wrong.

Conda is completely self-contained, so nothing will be overwritten. If you don’t add the conda init stuff to your bashrc (say no when it asks), then the environment will be totally unchanged until you source the activate script.