Problems with csparc2star- incorrect particles are extracted

Hi everyone,

I am trying to convert my particle stack from cryosparc to relion (originating from a homogenous/non-uniform refinement job), and then run an extraction job in relion using the particle coordinates.

I use the following command: *particles.cs *passthrough.cs --strip-uid

and then I change all optical group fields, as well as the micrograph path to point at the MotionCorr “frames” folder.

I should note that my cryosparc particles were extracted from micrographs that had been motion corrected previous to data processing, during data collection (i.e. they were not motion corrected in cryosparc or relion).

Using my converted .star file I can then extract particles from the relion micrographs, but when I inspect the extracted particles, they are junk… Seems I need to correct somehow my coordinates, but since I’m using the new version of pyem, when I add the flag --swapxy or --flipy, I get the message that it does this already done by default…

Does anyone know how to resolve my issue?


Correction- only for --swapxy I get the message it is done by default.
Seems I did not use --flipy previously.
Should I use this? Or --inverty?
I’m a bit confused how do I know when to use which flag.

Yes, try --inverty. You can display the particle picks with too, then it will be clear.

is there a trick to import back into cryosparc? I am running the latest pyem, particles go out of cryosparc smoothly via cs export → csparc2star → relion 3D class, no re-extraction at any point. However, when I import back into csparc, the particles look like junk picks.

You must be importing back but then re-extracting? Then flip micrographs in Y before extract. You don’t have to do that though, you can just use the Relion particle stacks directly.

Thanks Daniel! I was using the csparc stacks directly in relion hoping to avoid any re-extraction operation. When I imported back to csparc I chose “Ignore raw data”. I also tried including raw data on import, but obtained similar results. I tried both with and without re-extraction in csparc.