Problem lmporting compressed tiff files

I am trying to import *.tiff files on cryoSPARC (v2.9.0). The process is failing with the following error message:

imgdata = tiff.read_tiff(abs_path).sum(axis=0) * gainref
ValueError: operands could not be broadcast together with shapes (4092,5760) (8184,11520)

Can anybody help with this?
Thank you.

Hi @kplkmrgoutam,
Thanks for reporting. This error is saying that your gain reference file and the tiff data itself are of different sizes. In particular, the tiff data seems to be K3 non-superres data, while the gainreference is a superres K3 gain reference.
Any change you’ve used the wrong gain reference file?

I am having a similar problem. I have a dataset collected on a K3 (not super-resolution). I’ve tried importing the frames into cryoSPARC and performing motion correction, CTF estimation, and particle picking in cryoSPARC but when I tried to extract particles I got the error below. At each stage, the preview micrographs looked good (though I did notice the whole micrograph wasn’t picked - only a square area was picked out of the rectangular micrograph). Again this error was from the extraction job (650 pix box size; I also tried smaller boxes and binning but got the same error):

CPU: 1.91 GB] Traceback (most recent call last): File “cryosparc2_compute/jobs/”, line 1685, in run_with_except_hook run_old(*args, **kw) File “/usr/local/cryosparc2/cryosparc2_worker/deps/anaconda/lib/python2.7/”, line 754, in run self.__target(*self.__args, **self.__kwargs) File “cryosparc2_compute/jobs/”, line 65, in stage_target work = processor.process(item) File “cryosparc2_compute/jobs/extract/”, line 271, in process cuda_dev = self.cuda_dev, ET=self.ET, timer=timer, batch_size = self.batch_size) File “cryosparc2_compute/jobs/extract/”, line 83, in do_extract_particles_single_mic_gpu mic -= bg_full # bg subtracted ValueError: operands could not be broadcast together with shapes (4092,5760) (5760,4092) (4092,5760)

I thought maybe I had made a mistake with the gain reference so then tried importing the motion-corrected .mrc files. A colleague helped me check that all these files were in fact the same dimensions (5760,4092).

I did not have any error with the Import job but you can see that in the preview that the micrographs appear to be sized differently.

Can you advise as to what might be my problem?

Thank you!

Hi @cldurie,

Can you show us screenshots of the Overview tab of the original Import Movies job, and the parameters you used?
Did you happen to flip the gain reference when you imported them?

[CPU: 455.5 MB] Traceback (most recent call last):
File “cryosparc2_worker/cryosparc2_compute/”, line 85, in
File “cryosparc2_compute/jobs/extract/”, line 41, in run_extract_micrographs_multi
File “cryosparc2_compute/jobs/extract/”, line 517, in run_extract_micrographs
result = extraction.do_extract_particles_single_mic(mic, bg_bin, micrograph, particles_in, N, N_out, scale_const, overall_normalizer, bg_fwhm_A = 200, has_ctf=outputting_ctf)
File “cryosparc2_compute/jobs/extract/”, line 74, in do_extract_particles_single_mic
mic -= bg_full # bg subtracted
ValueError: operands could not be broadcast together with shapes (3838,3710) (3710,3838) (3838,3710)

I got similar issue when extracting particles from micrographs resulted from motioncor2 wrapper in Cryosparc V2.15.

I did try use rotate & flip options in the motioncor2 wrapper, or use a pre-rotated-flip gain (without the need to use rotate & flip options in the motioncor2 wrapper), however without success.

Any suggestions?

Have the same issue. Any ideas, @stephan?