Patched CTF failed with imported motion-corrected micrographs

I did motion correction in relion 4.0, and I want to pick particles in cryosparc. So I choose the “Import micrographs” option in cryosparc, and import the *_PS.mrc file in relion motion correction output file. This import process seems worked, as no error was reported. But, the following Patch CTF estimation failed with all micrographs, I assume the import micrographs process may still exits some problem that I do not know. Any suggestions on import motion-corrected micrographs in cryosparc? Thanks a lot!

The _PS.mrc files contain the sums of the power spectra. They are not the motion-corrected micrographs. Is that likely where things are falling apart?


1 Like

Hi, yang!
Thank you for your suggestion. I have checked the output file of the motioncor job in relion4.0, for each movie, it has two mrc files. As you have mentioned, the_PS.MRC file contains the sums of power spectra, I thus tried to import the other *.mrc file, cryosparc report an error: AssertionError: Unsupported MRC datatype:12. Now I’m quite confused. Normally, we use the *.star file to carry on the following data process in relion. While CryoSPARC can import particle .star files but not micrograph .star files. Do you have any more suggestions? Thanks a lot!

As you are using RELION 4, did you have float16 output set to “Yes”? I don’t think any cryo-EM suite except for RELION 4 can currently read float16 MRC files.

AFAIK, float16 support was added with Patch 220215 to v3.3.1. If you’re running that version (or later), then it might appear to be a genuine bug.


Yes! Finally find out why, thank you very much!

Lots of thanks! I would try this patch and see if it works!