Patch motion and RBMCorrection error on detached/attached projects?

i was trying out the new reference based motion correction and I got this error: [libtiff error] /media/J1/imported/007713835526180867606_FoilHole_29015055_Data_27902184_27902186_20231028_143958_fractions.tiff: Not a TIFF or MDI file, bad magic number 28233 (0x6e49)

it was giving this error for every micrograph so I just killed the job. As input I used the output micrographs from an extraction job. I also tried using the accepted exposures output from a curate exposures job… it didn’t help.

I also detached this project from one processing work station and attached it to another (if that matters).

any suggestions would be great!

update: I was wondering if this was a more general error so I ran again the patch motion job again and it gives this error:

Error occurred while processing J1/imported/002565519617177943737_FoilHole_28980879_Data_27902181_27902183_20231028_085135_fractions.tiff
Traceback (most recent call last):
File “/home/cryosparcuser/software/cryosparc/cryosparc_worker/cryosparc_compute/jobs/”, line 61, in exec
return self.process(item)
File “cryosparc_master/cryosparc_compute/jobs/motioncorrection/”, line 132, in
File “cryosparc_master/cryosparc_compute/jobs/motioncorrection/”, line 147, in
File “cryosparc_master/cryosparc_compute/blobio/”, line 70, in cryosparc_master.cryosparc_compute.blobio.prefetch.synchronous_native_read

IO request details:
filename: /media/J1/imported/002565519617177943737_FoilHole_28980879_Data_27902181_27902183_20231028_085135_fractions.tiff
filetype: 1
header_only: 0
idx_start: 0
idx_limit: -1
eer_upsampfactor: 1
eer_numfractions: 40
num_threads: 6
buffer: (nil)
buffer_sz: 0
nx, ny, nz: 0 0 0
dtype: 0
total_time: -1.000000
io_time: 0.006554

However if I import the movies again with a new import movies job and rerun patch motion correction with the newly imported movies the patch motion job runs fine.

As mentioned in the first post the project of these jobs was created and processed to a point with another cryosparc instance and then detached and attached to a different one…

So I am now wondering if deattchement/attachment is somehow causing this…

During import, data files are linked (guide), as opposed to copied, into the project directory (to preserve disk space). I suspect that


is a stale symbolic link. Is this correct?

aha ok! yes the symlink got broken…
although the raw movies and cryosparc directory are on the same hard drive. I detached the project from 1 cryosparc instance, unmounted the hard drive from the work station and physically moved it to another work station, mounted it and attached the project to the other cryosparc instance.

so the location of the raw movies are slightly different (only an underscore): /media/cryosparc_user/…/…/raw_data to /media/cryosparcuser/…/…/raw_data

so if I only want to remove an _ between cryosparc and user for all of the symlinks: prefix_cut = /media/cryosparc_user and prefix_new = /media/cryosparcuser will do that without changing anything else?

thanks alot! :slight_smile:

If you are referring to cli.job_import_replace_symlinks(), this should work.

CryoSPARC v4.4.1 includes a fix for missing details related to IO errors.