Particle location missing

I have imported particles without connecting them to micographs.
I have done some data processing/ classification jobs using the particles, and am trying to remove duplicates before I merge particles from different classification jobs. However, the remove duplicate job fails saying:

" 'Non-optional inputs from the following input groups and their slots are not connected: ’ + missing_inputs + ‘. Please connect all required inputs.’
AssertionError: Non-optional inputs from the following input groups and their slots are not connected: particles.location. Please connect all required inputs."

I think this is because the particle location is missing, as it says ‘empty’ for particle location in the inputs. Is there a way to get the particle location for the particles that have already been processed? I’ve tried “Re-assign particles” to get the missing particle location but it fails with the same error. I’m hoping I don’t have to import particles again with connected particles and perform all of the classifications jobs again…

Thank you in advance for the help!

You have to connect the micrographs to import the coordinates.

You also need coordinates to reassign - otherwise there’s no point.

You can export your subclassified imported particles and use --copy-micrograph-coordinates with the original .star file to get the coordinates, and then import the result - but this time connect the micrographs. That way will definitely work, without rerunning the classifications.

Thank you for the reply.
I’m little bit lost with exporting the particles and using --copy-micrograph-coordinates with the orignal. star file…

  1. By exporting particles, do you mean I should export the refinement job of the particles?
  2. what do you mean by “original .star file”? Should I convert the “particles.cs” file from the refinement job of the subclassified particles to a “.star” file, and is this what you mean by the ‘original .star’ file? If so, why do i need to export the job?

“–copy-micrograph-coordinates” is a parameter of (an util of pyem for exporting particles to relion from cryosparc ). your can do: cryosparc_xxx.cs --strip-uid --copy-micrograph-coordinates

Note that: the is the star file from relion job which you imported into cryosparc, eg: Extract/job325/

Then re-import this new star file"" with connection blob to micrographs. If still get errors, you can try to re-extract particles in relion, then import into cryosparc with connection blob to mics.

Thank you for the help!
I always get the following error when I try the --copy- micrograph

/programs/x86_64-linux/pyem/20220131/pyem_extlib/pyem-20220131-lksb/pyem/ FutureWarning: Columnar iteration over characters will be deprecated in future releases.

Did anyone have the same issue?

It’s not an error (just a warning). The output will be fine.

Also - years old versions of pyem from sbgrid are not guaranteed to work.