MotionCor2 error "No such file or directory"


When I performed MotionCor2 for correction ,

first 10 ~ 20 micrographs are motion corrected well.

But, few moments later, it showed error message like this and work fail.

Traceback (most recent call last):
File “cryosparc2_worker/cryosparc2_compute/”, line 78, in
File “cryosparc2_compute/jobs/motioncorrection/”, line 364, in run_motioncor2_wrapper
_,output_micrograph = mrc.read_mrc(output_path_abs)
File “cryosparc2_compute/blobio/”, line 104, in read_mrc
with open(fname, ‘rb’) as file_obj:
IOError: [Errno 2] No such file or directory: u’/media/yeonjin/no1_proc/Processing/Cryosparc/P2/J5/motioncorrected/FoilHole_3926844_Data_3940211_3940212_20191004_2202_Fractions_motioncor2_aligned.mrc’

In case of the [Full frame motion correction], it was performed perfectly.

However, I want to use the MotionCor2 in cryosparc.

How can I resolve it ?

OS: Ubuntu 18.04.3 LTS

Hi @jspark,

Could you email the output of cryosparcm joblog <your_project_id> <your_job_id> to For example, cryosparcm joblog P1 J123

- Suhail

1 Like

I sent the email.


Hi @jspark,

Can you try re-running this job? Can you also monitor the memory usage of your GPU (watch -n -.5 nvidia-smi) while this job is running and ensure you’re not running out of memory?

Dear Sarulthasan,

When I re-run the MotionCor2 and check usage of GPU memory, (total 6GB)

the usage is only about 60 %, Not fully used.

Also, when I change the setting about memory allocation, still, there is an error.

I’m sorry to bother you, but is there any other advice for it ?


Finally, I resolve it.

The problem is the path of data files.

At very first time, I saved my micrographs on


And I run the cryosparc project on


When I run the motioncor2 on cryosparc, the error was occurred.

So, I made the softlink of data in the Cryosparc folder like this


Finally, motioncor2 was run perfectly.

I really hope this document is helpful to others who are having problems.

1 Like