Mismatch between micrographs and movies with csparc2star.py

When I run polishing training in Relion, it warns:

  • Movies for the following micrographs are missing:
    [all of them]

My dataset was processed entirely in CS/CS Live and I exported micrographs and particles for polishing in Relion. I followed Method 2 in the pyem wiki.

I made symlinks to my doseweighted, aligned micrographs from CS in MovieExports/Movies/.
I made symlinks to my accepted movies in Movies/.

I create my micrograph star files with:

csparc2star.py --movie --micrograph-path Movies/  P70/J303/P70_S2_accepted_live_exposures.cs  MovieExport/corrected_micrographs.star  MovieExport/Movies

Following the lead of some helpful posts on this board, I check the micrograph star files and find that they link to micrographs in the wrong location - the last line should be MovieExport/Movies, not Movies:

rlnMicrographGainName Movies/GainReference_20231218.mrc
_rlnMicrographMetadata MovieExport/Movies/20231218_35deg_669-99_018_Dec19_15.56.16_X+1Y-1-2_patch_aligned_doseweighted.star
_rlnMicrographMovieName Movies/20231218_35deg_669-99_018_Dec19_15.56.16_X+1Y-1-2.tif
_rlnMicrographName Movies/20231218_35deg_669-99_018_Dec19_15.56.16_X+1Y-1-2_patch_aligned_doseweighted.mrc

I can correct the path in the star files with sed:

for file in ./*.star
   sed -i 's/_rlnMicrographName Movies/_rlnMicrographName MovieExport\/Movies/g' $file

and similarly can correct the paths for _rlnMicrographName in MovieExports/corrected_micrographs.star, but can’t figure out why I’m getting this output in the first place. Would appreciate if anybody could set me straight.


It’s a bug, I fixed it, so the micrograph paths are written alongside the micrograph star files as expected. Thanks.

1 Like