Local motion correction error: slots particles must be connected


getting error
assert is_connected, “slot %s.%s must be connected!” % (input_group_name, slot[‘name’]. assertion error: slot particles.location must be connected

I loaded my movies into cryosparc in ~15 groups for optics. I aligned, did CTF, extracted based on imported particle positions. Did 2D and 3D and everything looks fine. But when I try to do local motion I get the above error. I use the particles from the 3D run from above, and for movie input I use the aligned movies (output from full-frame motion job) rather than the imported movies.

any input appreciated, thanks.

also what does “multi” mean for the motion correction job types?

I just went through and double checked everything. All micrographs are loaded, all particles came from said micrographs. I tried running local motion on a different dataset and it worked fine. That dataset also has particles imported from elsewhere and re-extracted from cryosparc aligned movies, so that’s not the issue.

Is it possible this is a bug and I am getting this error due to having so many optics groups? My micrograph input for “movies (exposures)” has 14 inputs. Has anyone else experienced this issue?

Hi @orangeboomerang,

Can you try the following:

  1. create a local motion correction job
  2. connect all the micrographs
  3. connect the particles from your 3D refinement
  4. expand the input connection of the particles, so that you can see the low-level inputs going into the local motion job:
  5. find original import job where you brought in the particle locations, and go to it’s “outputs” tab. Find the “particles.location” output and connect that directly to the “particles.location” low-level input slot in the local motion job

Then, if you run the job, it should work as expected.

“Multi” for the motion jobs means multi-GPU enabled - there is a parameter in those jobs to select the number of GPUs to run on .

1 Like

thanks @apunjani !

yes when I expanded the particles slot in the local motion it was empty. Weird. Bug? Anyway I was able to find the particle location and drag them over as you suggested. However, this is a combination of 3 datasets that I’ve imported, and that particle location slot only allows 1 input. I tried to come the imported particles using the “particle sets > intersect” (with the hope that I could afterward import the locations as 1 set) but got errors no matter how I tried it.


Kinda less than ideal but I went and manually combined the imported particle star files into 1, then reimported the particles. Connected the output from that to the local motion and problem solved.

Thanks for the help.