Live set mask diameter


Live automatically sets the mask diameter for 2D based on the particle size set for picking. Usually I don’t want this. Is there a way to turn it off, if not would it be possible to add one? The default cryosparc behavior of just masking out the corners would be more generally useful here I think.


Hi Oli,

If I am understanding your question correctly, you can select the gear icon while building the job in Live, and then hop in the regular instance to set the value to ‘NONE’, or modify any of the defaults. Queuing the job then should behave identical to a regular cryosparc job.


Yes, that is what I do now, but that is somewhat awkward, particularly when running on a facility computer - I think this parameter would be better set from the Live interface

Oh yeah, definitely not an elegant way to go about it!


Hi @olibclarke, @Zuhaib,

Thanks for bringing this up! We’ve made a note of this and will look into adding the ability to set custom parameters for a job within the tab in the Live interface.

- Suhail

1 Like