Importing particles misses ~30%

  • imported movies, did alignment and ctf estimation in cryosparc.
  • take file from from a previous refinement (relion) and strip it down to have simply micrographname, xcoord, and ycoord. (as has worked fine in the past)
  • i used some python scripts to double check that the originating micrograph is present before importing.

when I try to import particles it succeeds but imports only about 28k particles, while the star file I pointed it to has ~42k particles.

This is confusing because had I set it up incorrectly it would have failed and perhaps said “cannot find micrograph for this particular particle” but that didn’t happen. So it found micrographs for ALL 42k particles and gave no errors, yet gave only 28k particles.

I double checked that there are no duplicate lines in the original 42k particles and there are not, each particle is unique.

I used to export a list and look at the particles which actually made it through import. The particles that made it into import seem to have nothing special about them compared to the ones that did not get imported. The micrographs for both are present.

When I make a new import star file of ONLY the particles which didn’t get imported the first time, and I try to import them… error. It says "Assertion error: could not find match for " (there is a blank space, but no micrograph name.

I double checked that the particles which were not imported do indeed have files in the aligned cryosparc folders and yes they’re there.

So confused. thanks for any help.

Hmm - sounds like a formatting error of some kind.

Why do you need to “strip down” the star file? What happens if you import it directly?


funny enough when I first tried this with full files I was running into the same issue: only a fraction of the particles got imported. I thought I’d simplify things by making the stripped down version of the particles file and that solved it. It’s frustrating that I’m now getting the same issue with the stripped down version.

I ended up going back and making the stripped down versions again, being very careful to set it up like the previous time I had done it successfully – it worked. So something about how my stripped down star file was looking caused the problem, and unfortunately I’m not sure what it was. Maybe the order of metadata… I put “_rlnmicrographname” as the first field. Anyway it was a headache. Hopefully avoid doing this in the future.