Importing particles and micrographs from CryoSPARC to Relion


I have a dataset for which I got lots of trouble getting decent 2D classes in Cryosparc even I tried very hard and modified the common parameters such as iterations, batches, marginalization,… that have extensively discussed. When I imported small batch of particles into Relion using csparc2star I got really good classes. So now I am migrating my Cryosparc picks to Relion and continue working there with 2D, 3D,… CS gave me good picks but unfortunately not good-looking classes. Relion just failed to pick or just requires much more optimization for my dataset.

I did MotionCorr in Relion, imported micrographs in CS and did Patch CTF correction. I have successfully imported my CS picks from a refinement job into Relion using csparc2star (as indicated here: Export from cryoSPARC v2 · asarnow/pyem Wiki · GitHub). However, I would like to know how I can reference and import micrographs from my Patch CTF into Relion so that I can work with both files. I also did micrograph curation after Patch CTF if that counts. I have seen --to-micrographs is used by some users but I could not find the proper usage.

So please, feel free to provide any feedback on this question.


Dear @platorre,
Firstly, you will need to retrieve the result of Patch CTF by the command “ exposures_ctf_estimated.cs passthrough_exposures.cs -r2”. Then check the path of mics present in and just make a directory correspondingly and link the mics to the directory.

Hi @Verdandy,

I created my and files. After importing them in Relion 3.1 I tried to do an extraction job but failed with error “Cannot read XXX_micrograph.mrc It does not exist”.

My (from Patch CTF) has the JXXX/imported/XXX.mrc format and in my relion folder I created the JXXX/imported path. In this path I linked my JXXX/imported/.mrc from Csparc. The ln command failed saying the argument is too long and tried-> "find micrograph_path -name ".mrc" | xargs ln -s -t link_destination_path". Probably this is the issue. Relion request the file ABC.mrc but in the JXXX/imported find 0102038182ABC.mrc (numbers+file name).

Thanks again.


It seems that something went wrong. Firstly, you may need to check whether the link of micrographs is validated and I would like to link the micrographs from the directory in which you have import the micrographs into cryosparc. For the JXXX/imported find 0102038182ABC.mrc issue, just edit your **** file
like “sed ‘s/[0-9]*_stack/_stack/g’ >”. Try again with the newly generated star file and good luck!

Dear @Verdandy

Everything seems to be up and running.