Import Movies Tutorial Error

I am new to CryoSPARC and just finished installing it (Single Workstation) and am trying to go through the tutorial. I receive an error when attempting to run the Import Movies job. I have tried restarting and reinstalling prior to this.

License is valid.

Running job on master node

[CPU: 80.5 MB]   Project P1 Job J1 Started

[CPU: 80.5 MB]   Master running v3.3.2, worker running v3.3.2

[CPU: 80.7 MB]   Working in directory: /home/wuit-3/cryotest/P1/J1

[CPU: 80.7 MB]   Running on lane default

[CPU: 80.7 MB]   Resources allocated: 

[CPU: 80.7 MB]     Worker:  wuit-3-MS-7C56

[CPU: 80.7 MB]   --------------------------------------------------------------

[CPU: 80.7 MB]   Importing job module for job type import_movies...

[CPU: 241.1 MB]  Job ready to run

[CPU: 241.1 MB]  ***************************************************************
[CPU: 241.1 MB]  Traceback (most recent call last):
  File "cryosparc_master/cryosparc_compute/", line 85, in
  File "/home/wuit-3/cryosparc/cryosparc_master/cryosparc_compute/jobs/imports/", line 710, in run_import_movies_or_micrographs
    path_glob = os.path.expandvars(params['blob_paths'])
  File "/home/wuit-3/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.7/", line 288, in expandvars
    path = os.fspath(path)
TypeError: expected str, bytes or os.PathLike object, not NoneType

Welcome to the forum @jbv.
How did you specify the path to the movies field Movies data path?

@wtempel It looks like I accidentally switched the two fields and also used a *.mrc which after pointing to the file directly fixed this issue.

I also identified a separate issue with the install in case anyone else has this error, as outlined in this post with the SSD cache location not being specified correctly.

Thanks for the help, I appreciate the community here and look forward to learning more.

Were you able to resolve that issue?

Yes, I fixed it by creating the directory in the SSD and pointing the install to it directly. Thank you!