Import ctf-corrected micrographs from warp

Hi there,

is there a way to import ctf-corrected micrographs (e.g. from warp) into cryosparc by now?

I would like to do template-based picking (using the micrograph CTF to filter the templates) from micrographs generated in warp. I have imported the micrographs as *.mrc from the average folder as written by warp and generated a template using relion_project. When I pass both to the template picker job in cryosparc I get the following error:

Traceback (most recent call last):
File “cryosparc_worker/cryosparc_compute/”, line 52, in
File “/home/emuser/emtools/cryosparc2/cryosparc2_worker/cryosparc_compute/jobs/”, line 848, in check_default_inputs
assert False, 'Non-optional inputs from the following input groups and their slots are not connected: ’ + missing_inputs + ‘. Please connect all required inputs.’
AssertionError: Non-optional inputs from the following input groups and their slots are not connected: micrographs.ctf. Please connect all required inputs.

I have seen a similar question here (, but it doesn’t seem to have an answer (yet).

Any help would be much appreciated.



This isn’t really a solution but a not-so-pretty workaround I used a while ago when I was trying to do the same thing. I basically did the micrograph preprocessing in Warp, imported micrograph averages in cryoSPARC, calculated micrograph CTF in cryoSPARC (CTFFIND4), and did the template picking. Then I took the picked particle location to Warp as star files (I hadto manually edit the star file to correctly connect particle locations to micrographs) and used “Adjust Particle Defocus” tool in warp. As per my understanding, it would then take particle locations from template picking and update defocus values to that calculated by Warp. Although, if you were to do CTF estimation in cryoSPARC anyway, I am not sure if updating defocus values calculated in Warp again would make a huge difference. In any case, this is the only way I can think of doing this, since cryoSPARC doesn’t allow importing micrograph metadata information, as far as I can tell. :confused:

Check “output constant CTF” when you import the micrographs.

Ah, I didn’t realize there was this option in v3.2. I tried that in v2.15, where import micrograph job evidently didn’t have this option. But even if one were to import micrographs with a constant ctf (which apparently makes the subsequent jobs ignore ctf entirely), I have to wonder how well the template matching would work.