How to improve the Ab-initio map quality

Hi everyone!

Here shows my 2D classification results. The quality of 2D seems good, but I can’t get the high quality map from Ab-initio job, the map has may wrong density., like some spike on the protein surface.

So, Is there any better Ab-initio parameters I can use?

Thaks a lot!

For ab initio you do not need a high resolution map. Your particles seems to be too small and needs better alignment. You need to be cautious while doing select 2D jobs. If you select bad classes, you tend to get such maps. Better use default parameters and just tune initial resolution to 12-8A. Should work fine.

Thank you for replying this,

The structure has an Alphafold predicted model. I use the predicted model as the good reference and do the hetero-refinement, the particle after hetero then run the 2D classification. I nearly kept all the particles and do the Ab-initio. So I think the alignment might be good because I use the Alphafold predicted model?

And the other question is how to define the “bad classes” in 2D clasification?

Ideally you should not use model as it creates model bias. I would suggest that you use topaz train with only good particles that you have from blob picker. Following you can use topaz extract. After that extract particles in the right box size with fourier cropping and do iterative 2D classification untill you get clean particles classes. After that go for Ab initio with 3 or more classes. Do put initial starting resolution as i advised. At this resolution you’ll be able to get some good initial model and remove junk. Then do a homogeneous refinement using default settings and use the high resolution model for heterogeneous sorting untill there are no bad classes coming up.

1 Like

Thanks a lot!

I will try the method you said.