How to get more filaments picked with Filament tracer?


I am processing EMPIAR10495 with cryosparc v3.1.0. According to the diagnostic image below, the thresholded cross correlation is able to recognize all filaments in the image. However, the pruned skeleton only contain a few filament. What parameters should I change to get more filaments picked?

Here are my parameters:

1 Like

Hey @Chen,

By a coincidence, I had actually processed this dataset a few months ago – I found that the cc map looks like it’s finding filaments but there are “bumps” in the filaments that make it disjointed after thresholding. I actually got better results using the template-free tracing option, with minimum/maximum filament diameters of 140 Å and 180 Å respectively (without inputting any templates into the job). The template-free option just looks for line-like features in the micrograph, so its “unbiased” and also tends to do better when the filaments vary in their contrast.

I used the following parameters and it seemed to help:

The job does require some tuning per-dataset; hopefully this helps!


1 Like

It worked with your parameters. Thank you so much.