How to combine two particles sets from two different projects in cryosparc 2.15?

Hi, all

I want to merge the particles from two different projects. I tried by using “import particles” and “import group results”, as a result, the errors occured like the .cs file can not be accept and unable to find /xx/xx/xx.mrc, respectively. Could you anyone tell me how to solve this? thanks a lot!


Hi @niu,

Is it possible if you can post screenshots of your workflow and the error message you recieved?
Also, are the particles from the two different projects the same particles, but with different parameters? Or entirely different particles?

Thanks for your reply.
The error like this:

The particles are from two different projects, which were collected in two different times with similar parameters, although both are from a same protein sample.

Hi @niu,

Can you confirm that the particles are in fact at /data2/NFF/20200710_928/P29/J5/imported/stack_*?
When you hit “Export” on a result group in the Outputs tab of a job, the entire result group will be placed inside the “exports” directory inside your project. Can you make sure you can find this folder and ensure it has all the necessary data?

Hi, stephan,

Thanks for your nice reminding. Following your suggestion, I solved this problem by exporting the result group from previous project firstly, then copying it into my current project and finally importing the whole job using " Import group results". Previously, I just simply copied the job into the current project without “Export”, which may have some problems.

thanks again.


1 Like

I also tried the same but it seems to be not working. Attached is the error screenshot below. Please have a look at this too!

Welcome to the forum @Jahnavi.
Please can you describe the export-import procedure that you followed?
If you have shell access to the computer running cryoSPARC, please run the command:
ls -lH <mrc_file>
where <mrc_file> is replaced with the full path of any one file that is listed as “Unable to find” and share with us the actual command that you ran and its output.

I exported the output from one project and copied the folder to the other project where I actually want to import the data and then I tried to import the .csg file through the import result group job.
Here is the output of the command:

What may have occurred:

  • symbolic links, not the actual data files to which those links point were copied
  • the actual files are not found on the “destination” computer to which the files were copied, either because
    • (A) the files are not present on the destination computer at all
    • (B) the files are present, but at a different mount point or path

Remedy for (A): Ensure that links are “dereferenced” during copying. Specifics depend on the command/program used for copying. A tar example is discussed in the guide. rsync and cp have applicable options also.
Remedy for (B): Adjust the symbolic links to point to the correct location of the files on the destination computer. The cli.job_import_replace_symlinks() may come in handy in this case (example).