Helical refinement fails at later iterations

Hi, running helical refinement job with non-uniform option on. Runs fine until one of the half maps gets weird and a couple of iterations later finishes with 84 A resolution. within the run it goes to 3.4A. No errors in the event log, in job.log there are couple of warning in plot utils about division by zero and invalid values encountered in sqrt. Here is an example of normal looking half map:

And a wrong one:

Any idea what could go wrong there?

Hi @mbs. This is indeed strange!

Since the early iterations seem to work well, I wonder if you have corrupted particles in your particle stack which break the refinement. Since the whole particle stack is not used at once, it’s possible these bad particles (if they exist) could break the refinement once they are present in a minibatch. Here are a few ideas we could investigate to see if this is the problem:

  1. Does this occur if you turn off the Use Non-Uniform Refinement parameter in the Helical Refinement job?
  2. If you use a subset of the particles (for instance, using the Particle Sets Tool job), does this problem still occur?

Hi @rposert, a little details on that issue. The dataset consists of two subsets, both run fine through helical refinement. I am checking now for corrupt particles, will tell you if I find some. Tried today with the full set turning off non-uniform refinement, it went fine to 3.3 A resolution (iteration 3, was using full dataset) but iteration 4 failed. As I said, two subsets separately worked fine; I could of course start trimming the set down from the end but it seems unnecessary at this point. And even more strange thing is that this particular set went through to completion once or twice before, so I am not sure what’s happened. Also, depending on the run it fails differently, sometimes one of the halfmaps looks just like featureless cylinder. Do you want me to send you job.log and may be event.log from one of the failed jobs?

Hi @rposert, Checking for corruption job just finished, no corrupted particles found. Anything else I could check?
Thank you

Hi @mbs. Thank you for sending us the logs for this job. Unfortunately, we don’t see anything that jumps out at us for you to fix. We recommend you continue processing the two subsets separately moving forward.

Hi @rposert, I understand. WIll send you an update if I find something useful.
Thank you, Michael