Helical refine somehow uses x as axis

Dear cryoSparc team

I encountered this weird bug yesterday. It looks like the “Helical Refinement” job is using x-aixs as symmetry axis at the beginning, even it says using z-axis?

If I turned on the input option “Do symmetry alignment”, which I thought will fix this issue, it gave this error message. Any thoughts?

[CPU: 899.0 MB] ====== Masking ======

[CPU: 3.00 GB] No mask input was connected, so dynamic masking will be enabled.

[CPU: 3.00 GB] Dynamic mask threshold: 0.3000

[CPU: 3.00 GB] Dynamic mask near (A): 6.00

[CPU: 3.00 GB] Dynamic mask far (A): 14.00

[CPU: 3.00 GB] Dynamic mask z-clip fraction: 0.850

[CPU: 3.00 GB] ====== Initial Model ======

[CPU: 3.00 GB] Resampling initial model to specified volume representation size and pixel-size…

[CPU: 3.01 GB] Aligning initial model’s helical axis to z-axis.

[CPU: 3.51 GB] Aligning initial model to symmetry.

[CPU: 5.39 GB] Traceback (most recent call last):
File “cryosparc_worker/cryosparc_compute/run.py”, line 84, in cryosparc_compute.run.main
File “cryosparc_worker/cryosparc_compute/jobs/helix/run_refine.py”, line 644, in cryosparc_compute.jobs.helix.run_refine.run
File “/home/pawel/cryosparc2_worker/cryosparc_compute/alignment.py”, line 221, in align_symmetry
errs = compute_symmetry_errs(rs,symop,gfV,gfVnopre,radwn,cuda_dev=cuda_dev,stream=stream)
File “/home/pawel/cryosparc2_worker/cryosparc_compute/alignment.py”, line 159, in compute_symmetry_errs
gP = (gpuarray.empty((N_R,N_T_aligned),n.float32),
File “/home/pawel/cryosparc2_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/pycuda/gpuarray.py”, line 210, in init
self.gpudata = self.allocator(self.size * self.dtype.itemsize)
pycuda._driver.MemoryError: cuMemAlloc failed: out of memory

The box size is 512x512, we were running jobs fine for a larger box size (768x768). Our cryosparc version is v3.2.0.

Many thanks!

1 Like

Dear @Jerry,

Thank you for the report – we’ve taken note of the issue in symmetry alignment for helical symmetry and will fix this in an upcoming release. As a workaround, does disabling both the “Do symmetry alignment” and “Align input structure to helical (z) axis” parameters alleviate the axis alignment issue?



Thanks Michael. I actually just turned off this option “Align input structure to helical (z) axis” to bypass the bug. I think it will work as long as my initial input volume is proper aligned to z-axis.

This bug is fixed in v3.3.1 (released December 1, 2021). Thanks!

1 Like