Helical refine job 'rescaling initial reference by a factor of nan" error

Howdy troops.
A strange little bug/error I am encountering. I am running a helical refine job, however i am encountering an error at the beginning of the job where the initial model is rescaled by a non numerical factor as written above. The result is empty plots as there is no initial model to align particles to.

The error occurs regardless of the input initial model; iv’e tried user input models, auto generated models and cylindrical models. I had the same issue the other day, i fiddled with the inputs and restarted the job a few times and it eventually worked but it’s not clear how i fixed it.

Anyone seen something like this? I should note that the particles are of a different binning factor relative to the initial model (initial model is 400 pixels, particles are 400 binned to 200), but I didn’t think this would be an issue given the initial model is typically resampled to the input particle box parameters.

So i figured out which paramter was causing this issue. It seems to be the ‘window inner radius’. If set to 0.99, the nan error occurs. If set to a smaller number (0.95 for instance) the job runs normally.


Hi @jimhbean

Your observation makes sense – the window inner radius must be strictly less than the window outer radius or else there will be a division by zero, causing the nan.


Hi Michael
Thanks for your reply, that makes perfect sense :slight_smile: