FileNotFoundError: [Errno 2] No such file or directory in MotionCor2

Dear all,

I need your invaluable help and experience. I know that a similar problem already arose and has been discussed/solved in the past, but I’m not able to solve it myslef:

I’m using the last cryoSPARC version (4.2.0) and I want to use the last MotionCor2 version (1.6.3). When I try to run the job, I get this error message:

Traceback (most recent call last):
  File "cryosparc_master/cryosparc_compute/", line 96, in
  File "/home/agwilson/Software/cryosparc/cryosparc_worker/cryosparc_compute/jobs/motioncorrection/", line 397, in run_motioncor2_wrapper
    global_shifts = parse_global_alignment(full_frame_log_abs)
  File "/home/agwilson/Software/cryosparc/cryosparc_worker/cryosparc_compute/jobs/motioncorrection/", line 21, in parse_global_alignment
    with open(full_frame_alignment_log) as logfile:
FileNotFoundError: [Errno 2] No such file or directory: '/home/agwilson/HP018/221207_Wilson_HAS32/CS-cmv-gp48-spd-cs-processing/J47/motioncor2_logs/00-Patch-Full.log'

I saw in another discussion that a similar issue was solved with a soft link of the movies inside the cryosparc project directory, I already tried without success.

I saw in the MotionCor2 building step this message:
Path to MotionCor2 executable. Run cryosparcm cli 'set_project_param_default(project_uid, 'exec_param', path)' (where project_uid is your project number (e.g ‘P12’) and path is the absolute path to the MotionCor2 executable) to keep this parameter consistent across this project.
I tried the command but I only got “SyntaxError: invalid syntax”.

Do you have any idea how I could resolve this issue?
Thank you in advance for your help and attention.

From my experience, cryoSPARC doesn’t work well with the new versions of MotionCor. The highest version that seems to be working is 1.4.5.

@daddea Support for newer versions of MotionCor2 is on our roadmap for a future software release.

1 Like

Thank you so much for the reply @wtempel .

So it’s a problem related to support, I’m not doing any stupid error?

@daddea It seems that the newer version of MotionCor2 organizes its output differently from older versions, and the current release of CryoSPARC is not (yet) aware of these changes.