FCC model fit fails in RBMC

Hi,

I have a problem with the Reference Based Motion Correction. FCC model fit is giving me an empty white window. I am guessing it is a bug because of white space in the Frame vs Resolution FCC at high Resolution, which in turn may be caused by reaching the Nyquist? I will try go back to reconstruction and instead of Icosohedral symmetry, I will use C1.

My pipeline was simple:
Import Movies: pixel size 0.8456
Patch Motion Corr → Patch CTF → Picking → Extract 2x bin → Classifications → Extract no bin → Homogenous Refinement with I symmetry → RBMC (standard settings)

I searched the forum and found that someone has already reported it:

I have essentially the same problem and I can see the same gap in the FCC at high resolutions in that thread. No thumbnails, but also I don’t think that particles are ‘extracted’ after the motion correction, because subsequent Refinement fails completely.

J30_fsc_for_volume_0


I can confirm that refinement using C1 instead of I helped. I did not reach Nyquist. Frame vs Resolution FCC graph is complete (no white space at high resolution) and FCC model fit worked.
0


I don’t think it’s related to hitting Nyquist as I tried RBMC to 8K from a 4K physical-Nyquist limited reconstruction and it succeeded (and the 8K sampled refinement got about 15% past Nyquist, which given the particle count and FSC curve was around where I expected).

Hi @Lukasz_K, I don’t think it’s related to hitting the Nyquist either, but as you’ve noticed, in the FCC plot in your first example, the last column of pixels is white. This indicates that column contains NaNs or infinities. Why exactly I’m not sure, but if switching from I symmetry to C1 fixed it, with no other changes, that suggests that the issue lay with the reference and not with the particles themselves. Have you tried looking at the I map in, say, Chimera? Does it look fine?

Hi hsnyder,

yes. the map is completely fine. Maybe the infinities are there because pixel size I used (0.8456) has too many digits after the decimal, and CS at some point has averaged the Nyquist to 2 x 0.84 = 1.68, instead of 2 x 0.8456 = 1.6912 ? In such case I would not have data between 1.68 and 1.6912, that is why the column contains NaNs ? The maximum resolution in the FCC graph (frames vs Resolution) expands to higher value with I symmetry, but it doesn’t say what the maximum actually is.

Hi @Lukasz_K, interesting point. I’ll note this down to add a guard against the scenario you’re proposing, in case that is in fact the issue.