Error in Topaz Train - cryosparc v3.1.0

Hi all,

I ma processing negative stain micrographs and trying to use topaz train to better pick my particles that are hard to find. I get the following error.

Kindly help. Thank you.

Hello!

I’m new from cryoSPARC and here the students will use Topaz too.

According to this guide (https://guide.cryosparc.com/processing-data/all-job-types-in-cryosparc/deep-picking/deep-picking) the latest version of Topaz compatible with cryoSPARC is 0.2.3 in your image I see that you are using version 0.2.4 and maybe this could be the problem.
This guide does not have a publication date so I believe it is the last valid instruction for installing Topaz.
Try to downgrade topaz version.

Regards.

Hi chari1,

This error is coming from Cryosparc’s Topaz wrapper script. It looks like you put the scale value in correctly as 16. This script multiplies by the pixelsize. Can you check on that?

Best,
-Alex

Hi Alex,

I tried 2 different downsampling factors - 4 and 16. I get the same error.

Hi chari1,

Can you check the pixelsize of the images?

Thanks,
-Alex

I have the same error with a/pix of 2.18
command: /programs/x/topaz/0.2.4/bin/topaz preprocess --scale 4 --niters 200 --num-workers 20 -o

Dose anyone figure the problem?
Topaz and CS both run under Python3 and I try Topaz 0.2.3/4/5 all with the same error.
The A/pix is 2.18

CPU: 218.1 MB] Traceback (most recent call last):
File “cryosparc_worker/cryosparc_compute/run.py”, line 84, in cryosparc_compute.run.main
File “/data2/software/cryosparc/cryosparc2_worker/cryosparc_compute/jobs/topaz/run_topaz.py”, line 224, in run_topaz_wrapper_train
new_psize = psize_A_list[idx] * downsampling_scale
TypeError: can’t multiply sequence by non-int of type ‘numpy.float32’

Hi all, this is indeed a bug in cryoSPARC. We’ll be issuing a fix in an upcoming release. Will update here when that’s available.