Error in 2D classification procedure only

solved

#1

Dear cryoSPARC team,

I have updated the cryoSPARC to the version 2.5.0. Everything runs well except the 2D classification. The error message is shown as attached.

The project has:
image size - 320x320 pixels
particle number - 1,378,319
number of classes - 200; max resolution for alignment - 10 A; 4 GPUs (GTX Titan Xp) have been identified.

Many thanks for helping!

All the best,
Po-Lin


#2

Hi @holmeschiu,

We’ve recently seen this error come up here: Error during refinement with C4 symmetry

We’re still not entirely sure about what may be causing this- although after a little digging online, some people have said that completely reinstalling any NVIDIA drivers/ CUDA packages helped them. Is it possible for you to try to install the latest version of CUDA, and then recompile pycuda? You can do this by following this post: Cryosparc v2.4.6 w/cuda 10?

If you are not able to install a new version of CUDA or reinstall your current version of CUDA, you can try reinstalling cryoSPARC: https://cryosparc.com/docs/reference/install/#forced-update


#3

Dear team,

Thanks for the suggestions!

I actually tried to remove the old CUDA 9.0, and install CUDA 10 by compiling with gcc 7. It just worked!

Thanks for the help again and I will also note your suggestion.

All the best,
Po-Lin