Error clearing old jobs after upgrade to v3

When I tried to clear and run a 2D Class after update it gave me the following error message.

“class2D_estimate_in_plane_pose” parameter not available. This job may be stale. Please try the following steps in order until the issue is resolved: 1. Build a new job and try again. 2. Run the following via command line: cryosparcm cli “refresh_job_types()”. 3. Ensure no orphaned cryoSPARC processes are running in the background.

What can I do?

Hi @jiskander, can you please run the following commands via the command line:

cryosparcm cli "reload()"
cryosparcm cli "refresh_job_types()"

I ran both but still same warning and jobs fail

Can you please try cryosparcm stop and then ps -ax | grep "supervisord" to find any potential orphaned processes, and kill those before restarting cryosparcm start

This did not solve it either.

I am not allowed to clear the job and is marked completed, as shown in screenshoot

@jiskander Can you please build a brand new job and try running it?

New or cloned jobs run fine, old ones are the ones I cannot run

@jiskander Yes this is the expected behaviour; old jobs that are cleared and tried to run again will fail in new versions, if any changes have happened to the parameters of that job type. After a version update, you should always clone and run the job (i.e, not clear and re-run). Thanks!