EMPIAR-10073 importing error

Dear All,

My cryosparc version is v3.0.1. When importing dataset EMPIAR-10073 based on
" 1. Click on the “Job Builder” button on the top right of the desired workspace and build an “Import Particle Stack” job.
2. In the “Particle meta path” parameter, fill in the full (i.e. absolute) path of the shiny_correctpaths_cleanedcorruptstacks.star file.
3. In the “Particle data path” parameter, fill in the full path of the directory that contains the .mrcs files. If you downloaded directly from EMPIAR, this would probably be something like .../10073/data/", it failed. The message including the error was as following:

"License is valid.

Running job on master node

[CPU: 78.3 MB]   Project P4 Job J36 Started

[CPU: 78.5 MB]   Master running v3.0.1, worker running v3.0.1

[CPU: 78.7 MB]   Running on lane default

[CPU: 78.7 MB]   Resources allocated: 

[CPU: 78.7 MB]     Worker:  localhost

[CPU: 78.7 MB]   --------------------------------------------------------------

[CPU: 78.7 MB]   Importing job module for job type import_particles...

[CPU: 246.2 MB]  Job ready to run

[CPU: 246.3 MB]  ***************************************************************

[CPU: 246.3 MB]  Importing particles from  /home/user/empiar10073related/shiny_gz/shiny_correctpaths_cleanedcorruptstacks.star

[CPU: 246.3 MB]  File extension is  star

[CPU: 246.3 MB]  Importing star file.

[CPU: 313.2 MB]  --------------------------------------------------------------

[CPU: 313.2 MB]  Loaded star file with 138899 items

[CPU: 313.2 MB]  Fields loaded from star file:  ['rlnVoltage', 'rlnDefocusU', 'rlnDefocusV', 'rlnDefocusAngle', 'rlnSphericalAberration', 'rlnDetectorPixelSize', 'rlnCtfFigureOfMerit', 'rlnMagnification', 'rlnAmplitudeContrast', 'rlnImageName', 'rlnCoordinateX', 'rlnCoordinateY', 'rlnNormCorrection', 'rlnMicrographName', 'rlnGroupName', 'rlnGroupNumber', 'rlnOriginX', 'rlnOriginY', 'rlnAngleRot', 'rlnAngleTilt', 'rlnAnglePsi', 'rlnAutopickFigureOfMerit', 'rlnClassNumber', 'rlnLogLikeliContribution', 'rlnRandomSubset', 'rlnOriginalParticleName', 'rlnNrOfSignificantSamples', 'rlnNrOfFrames', 'rlnMaxValueProbDistribution']

[CPU: 313.2 MB]  --------------------------------------------------------------

[CPU: 313.2 MB]  Reading particle data locations...

[CPU: 313.2 MB]    Reading rlnImageName to get indices and paths..

[CPU: 373.9 MB]    Warning: Parameter particle_blob_path was set, which overrides rlnImageName despite the latter being present in the input star file.

[CPU: 373.9 MB]    Parameter particle_blob_path was set and is a directory, so will be used as the search base for finding referenced data paths in the star file.

[CPU: 373.9 MB]  Searching for linked data files...

[CPU: 374.3 MB]  --------------------------------------------------------------

[CPU: 374.3 MB]  Compiling CTF information...

[CPU: 382.6 MB]  Warning: No micrographs were connected as inputs, so correspondences cannot be found, so output will not contain pick locations for particles.

[CPU: 382.6 MB]  --------------------------------------------------------------

[CPU: 382.6 MB]  Compiling particle pose information...

[CPU: 382.6 MB]    Converting euler angles..

[CPU: 415.0 MB]  --------------------------------------------------------------

[CPU: 415.0 MB]  Particle information has now been imported for 138899 particles, creating outputs...

[CPU: 415.0 MB]  Found references to 2348 unique data files

[CPU: 415.5 MB]  Import paths were unique at level -1

[CPU: 415.5 MB]  Example imported relative path:
[CPU: 416.0 MB]  Reading MRC file headers to check shape...",

And the failure message was as following:

" File “cryosparc_master/cryosparc_compute/run.py”, line 84, in cryosparc_compute.run.main
File “/home/user/mycryosparcv3/cryosparc_master/cryosparc_compute/jobs/imports/run.py”, line 352, in run_import_particles
hdr = mrc.read_mrc_header(mrc_file)
File “/home/user/mycryosparcv3/cryosparc_master/cryosparc_compute/blobio/mrc.py”, line 55, in read_mrc_header
[hdr[‘nx’], hdr[‘ny’], hdr[‘nz’], hdr[‘datatype’]] = header_int32[:4]
ValueError: not enough values to unpack (expected 4, got 0)".

I am looking forward to getting your advice on how to have the job “Import Partcle Stack” successfully done for “Case Study: Yeast U4/U6.U5 tri-snRNP”, i.e., to successfully import the EMPIAR-10073 datasets by “import particle stack”.

Sincerely yours,

I have CryoSPARC v3.2.0 (5th Aug, 2021). I have succeeded in “Import Particle Stack”.

However, when I tried to import for the first time, I also had several errors. This is how I solved my errors.

  1. I moved the all particles, which were downloaded from EMPIAR-10073, to the directory (e.g. /data/), which was identical to the directory, which contained the .star file. In other words, I moved all the particles to a /data/ directory (/data/.mrcs). I also moved the .star file to the /data/ directory (/data/.star).

  2. I looked at the data size of the particles in the EMPIAR-10073, and the data size of the particle in my /data/ directory. The data size in my /data/ directory was smaller than the data size in the EMPIAR-10073. I noticed that some of the particles were not downloaded to my /data/ directory with a single click. Therefore, I downloaded missing particles for the second download, for the third download etc. until I got all the particles. After I downloaded all the particles, then I started the import operation.

  3. I set “Length of input micrograph path prefix to cut” as 15, and “Length of rlnMicrographName path prefix to cut for query” as 15.

I wish this information would help start using the CryoSPARC.