Deep Picker Error: No particles corresponding to input micrographs were found

I am trying to use Deep picker but got the following error:

[CPU: 396.9 MB]  Traceback (most recent call last):
  File "cryosparc_worker/cryosparc_compute/", line 84, in
  File "cryosparc_worker/cryosparc_compute/jobs/deep_picker/", line 255, in
AssertionError: No particles corresponding to input micrographs were found. Ensure that non-zero particle picks were input and that the particle picks are from the input micrographs.

It is frustrating because I used DeepPicker for another project and it worked but it is not working on the current project. Apparently, the same problem was discussed back in January but there was no solution presented. Our CS is the latest version 3.2.0 and all patches have been integrated. Any solution to this problem Thanks
Best Yuro

I had the same problem and saw someone suggesting in an old post to change “Number of parallel threads” to 1. After changing it for my job, the training started without a problem. Maybe you can try it too.

Thanks for your response. I think Michael from cryosparc team suggested that number of parallel threads=1 should be used back in Jan 2021. I have tried this but it did not work. Perhaps after installing a new patch though nothing to do with this error, I may try it again.
Best YT

Hi @yurotakagi this indicates that either (1) the job received no micrographs or (2) the particle dataset can’t be matched up to its corresponding micrographs due to how the micrographs/particles were generated. To help with further troubleshooting, can you post a screenshot of the workspace up to the failing Deep Picker job, in Tree view?

Dear nfrasser
Thanks for your attention. I was using the sub-set of particles identified by Ab-initio reconstruction - “particles” from Ab-initio were the input for "particles. For micrograph, I used (i) “Micrographs” from “Particle extraction” or from “Exposure curation”. Both approaches got the same errors. Please see the attached screen shots I hope you and your team will find the solution to this problem. Best Yuro

I am seeing the same problem. Works for some particle/micrographs but not others even after reextraction.

I too am having the same problem. I use the micrographs from “inspect particle picks” and cleaned-up particles from “select 2D class”. I use the exactly the same procedure from the start (motion correction, CTF estimation, etc.) all the way to deep picker, but it works for some datasets and not for others.