Database error (spawn error)

Dearr all,

today we got a an error where the cryosparc database had the status: EXITED. The installed version is 3.3.1.
This has happened before and ussually I was able to repair the database with:

mongod --dbpath ./ --repair

This command finishes without any error but when I try

cryosparcm start

I get:

Starting cryoSPARC System master process…
CryoSPARC is not already running.
database: ERROR (spawn error)

The ERROR pops up really quickly, there is almost no delay.

Then I tried to restore the database from the daily backup and got the exact same error:

cryosparcm restore --file=/path/to/the/database_backup_Tuesday.archive
Restoring from /path/to/the/database_backup_Tuesday.archive
CryoSPARC is not already running.
Starting mongod incase it’s not already running.
database: ERROR (spawn error)

Could there be an issue with mongod?

cryosparcm status

now reports:

CryoSPARC process status:
app STOPPED Not started
app_dev STOPPED Not started
command_core STOPPED Not started
command_rtp STOPPED Not started
command_vis STOPPED Not started
database FATAL Exited too quickly (process log may have details)
liveapp STOPPED Not started
liveapp_dev STOPPED Not started
webapp STOPPED Not started
webapp_dev STOPPED Not started

I also rebooted the machine, no change.
How can I troubleshoot this further? Which logs could I check?


What does
cryosparcm log database

Hi @wtempel,

thank you for the tip!!
Of course it was something simple in the end. I went through the log and noticed:

Disk quota exceeded

So yeah we reached the disk quota on that folder set by the admins at our HPC…
CS works now just fine.

Thank you very much for the quick reply!
You can consider this thread closed.

Best regards!