Data transfer // re-connection on the new drive

Dear colleagues,

We want to transfer the projects created by the CS to the new drive.
We have an issue mounting the old drive with CS projects.


The old drive where all the CS projects were previously created and worked over is now inaccessible from the CS. (mounting issue)

At the same time – we managed to copy those projects from the inaccessible drive directly to the new drive, where we can now access with CS.

Could you please advise how to re-connect the copied projects to the CS on the new drive?

Initially, I thought to

  • De-attach the old projects (from the old drive).
  • Attach the copied one from the new drive.

But since the old drive is inaccessible, I cannot do that.

Thank you.

Kind regards,

@Dmitry A question (not a suggestion that you should do so at this time): Can you hypothetically mount (and, possibly, create necessary symbolic links) such that the CryoSPARC project directories can still be accessed under the same path as they were accessed on the old drive?

1 Like

@wtempel - from the same server it doesnot seem to be possible.

So what I tried -
a) to create a new folder called old_drive
b) tried to make a symbolic link to it from the old drive (called nas/cold)
sudo mkdir /old_drive
sudo ln -s /nas/cold/cryosparc_projects /old_drive/cryosparc_projects

the old_drive/cryosparc_projects was created but “cryosparc_projects” is red - so the symbolic link is broken.

The issue is still that
XXXX@cryotem-access:/old_drive$ cd /nas/cold
ls -l
total 0

So as you see it is not possible from the sever.

Maybe it is possible from the other pc that can see the containment of the nas/cold folder. But then again not sure if the server will see any file.

p.s. the funny this is that when one types -

XXXX@cryotem-access:/nas$ mount | grep /nas/cold on /nas/cold type nfs4 (rw,relatime,vers=4.1,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=,local_lock=none,addr=,_netdev)

It seems to be correctly mounted.

Did you expect to find /nas/cold/cryosparc_projects?
Is the “new drive” supposed to be and actually mounted on
What is the output of the
df -h command on

1 Like