CTF estimation error with high mag


I am running the latest cryoSPARC Live version on a dataset with rather high magnification because we are looking at a small particle. The data is from a K3 in superres with a pixel size of ~0.2Å/px. During the live processing the motion correction step works fine, but CTF estimation fails with:

Traceback (most recent call last):
File “cryosparc2_worker/cryosparc2_compute/jobs/rtp_workers/run.py”, line 92, in cryosparc2_compute.jobs.rtp_workers.run.rtp_worker
File “cryosparc2_worker/cryosparc2_compute/jobs/rtp_workers/run.py”, line 224, in cryosparc2_compute.jobs.rtp_workers.run.process_movie
File “cryosparc2_worker/cryosparc2_compute/jobs/rtp_workers/run.py”, line 522, in cryosparc2_compute.jobs.rtp_workers.run.do_patch_ctf
File “cryosparc2_worker/cryosparc2_compute/jobs/rtp_workers/run.py”, line 523, in cryosparc2_compute.jobs.rtp_workers.run.do_patch_ctf
File “cryosparc2_worker/cryosparc2_compute/jobs/ctf_estimation/patchctf.py”, line 66, in cryosparc2_compute.jobs.ctf_estimation.patchctf.patchctf
File “cryosparc2_worker/cryosparc2_compute/jobs/ctf_estimation/patchctf.py”, line 83, in cryosparc2_compute.jobs.ctf_estimation.patchctf.patchctf
AssertionError: Get rid of patches that are too close to edges

Is there a setting I can change to make this work? Processing for datasets with larger pixel sizes works fine, so I suspect that the high magnification/small pixel size is the culprit.


Does it fail if you manually specify the number of knots (patches)? 4 or 5, say.

I tried anywhere between 5 to 1 knot(s) in x and y and get the same error message. I have not tested it yet outside of the live version to see how it behaves there.

To follow up on this, the same error occurs in the standard version during CTF estimation. After testing a few mags and pixel sizes, it seems that anything less than 0.2A/px triggers the error (0.19 is not working 0.22 is). For what it is worth, running the CTFFIND wrapper or GCTF works fine.