CS version 3.2 import error


While updating my 3.1 CS it got corrupted so I had to install a new instance of CS 3.2.
However, after applying the patch, I can not import my old jobs ran on v3.1.
When I import on 3.2, it shows its importing for quite a while but I can not see any workspaces after it finishes. No jobs are also visible in the imported section.

This is after import finishes. Looks like they completed well but when I get inside I see this…

No visible workspaces or jobs !!

Somebody please help me out with this problem.

I have seen it before. Try to create a new workspace and all jobs should be restored after refresh.

I’m not sure if that would work if I have multiple workspaces in an imported project.
I imported one project and created one workspace which only brought jobs from only one workspace, rest of them are lost somewhere.
I’m trying another project. Will update the thread if works.
Why is this happening I’m not sure. Is it a kind of bug or I’m doing something wrong?

So after using all the patch and everything the import job is really messy and not good at all. Please release a patch or suggest something to make it workable.
All the workspaces are combined. I can not find a way to separate the workspaces.
This is what it looks like following @dzyla 's method in tree view only.

All messed up.
However, if I go to other thumbnail view, I see nothing.

Please suggest a way out of this.

Have you tried to restart cryosparc? Some weird things sometimes happen.

Another possibility: now when you updated the folder to cs3.2 try to re-import it. Do not remove it from cs because it can remove files. I would suggest renaming the folder and then re-import it and see whether it fixed that.

Hi @diffracteD,

Sorry for all the troubles, and thanks @dzyla for helping!
Like @dzyla said, make sure not to hit “delete” project once it’s already imported, if you only have one copy of your project- it’ll wipe out the folder you imported from.
What patch version are you on (you can check the version on the dashboard)?
If you import your project on the latest patch, you shouldn’t have any issues.

Hi @stephan,

Thank you for responding. I’m using the most recent patch version as mentioned at the top of this cryosparc discussion forum.
Strange thing is that the import worked (nicely imported with corresponding workspace) for only 1 project and failed (no workspaces, all clumped together in tree view only) for all the other projects.
I’m not sure what’s the issue.

Thank you.

Hi @diffracteD,

Sorry for the late reply. Is it possible that some of the files in the projects that are not being imported properly were overwritten? Do you have access to the original project directories? Can you try importing those instead?