Created mask does not align with EM map


I am trying the create the mask around the specific region in the em density map. First I used segger to select the map region for mask creation and later volume import and mask creation job in cryosparc was used to create the mask. After downloading the mask, I don’t observe the perfect superposition of the mask and EM volume. Could you suggest to me where is the problem?

In the attached image, the grey map corresponds to the actual region from the EM map and the yellow map is a mask downloaded from cryosparc.


not sure about segger part, no experience. typically, this would be an issue of box size, and the mask should be resampled to match pixel size, box dimensions, and relative position prior to import to cryosparc.

1 Like

Hi @sjadhav ,

I’m seconding @CryoEM2’s remarks. After selecting a segmentation from segger to identify the region of the protein you are interested in, you’ll need to output that selection to a mrc file (in the segmentation tool in ChimeraX, this is done by selecting the desired regions so that they’re highlighted in green, then “File” > “Save selected regions to .mrc file”). In doing so, ChimeraX may modify the box size such that it doesn’t coincide with the original volume. To fix this you will need to use the vop resample command as such: vop resample #<id of selected regions mrc> onGrid #<original map mrc>.

After you save this to a mrc, import to CryoSPARC, generate a mask, and then open this mask in ChimeraX do you still notice an error in alignment? Can you confirm that the box sizes for both the mask and the original density are identical?



There should be an option in the Extract function of SEGGER to export the segmented volume area into the original box size.


At the top of the “Extract” window, the radio button “Same as map from which the densities are extracted”.

1 Like

Thanks a lot for the reply. It worked

Thanks for the detailed protocol. It works now!!!