Couldn't open Coot for looking up the volume

Hi all,

Recently we solved a CryoEM structure and I am planning to look at the map in Coot on my MacBook. I downloaded the ccp4 suite which the Coot is in that package. After installing the ccp4 software, when I click the Coot icon, it didn’t run (seems it didn’t have any respond), so I installed the xquartz software and restarted the computer, the thing stayed the same and I still couldn’t open the Coot. Did this thing happened to you before? Do you know what might be the possible reasons? And what can I do to open the coot?

Thanks in advance!

I’m much more familiar with windows and linux and not as much with Mac, but my questions/thoughts:

  1. Does your device contain intel or mac silicon?

  2. Have you tried calling coot from the terminal (IIRC coot is in /bin)? When you do this, what errors do you see?

  3. CCP4-coot is generally the most painless way of getting a stable version of coot, but I’ve had issues with the latest build (CCP4 8) on Ubuntu 20. Have you tried installing an earlier version of coot (independently of CCP4) or even going back a generation of CCP4 to CCP4 7-1?

I’m sure during your troubleshooting you’ve seen this, but just in case you have not:

As a last resort (this rarely works for me and takes hours) you can try to compile coot yourself using Paul’s install script on github.

Dear Sebk,

Thanks for your information! Right now the problem has been solved. We tried two different thing:

First we installed a older version of CCP4 7.0; and second,
We installed Xquatz from the CCP4 official website and followed the instruction.

After we have done that, the Coot can be successfully run on my Macbook.


1 Like

That’s great! I’m glad you figured it out.

Good luck building!

I have same situation that I could not open COOT once I install the ccp4 8.0. I could not find the older version of ccp4 7.2. Do have any idea to download it or open COOT in ccp4 8.0 in Mac?