Converting back to relion, Imported micrographs changed names


This a probably a question for DanielAsarnowand the CryoSPARC team together.

I’ve been having problem converting particle stacks back to relion. Usually I extract in relion and 2D in CryoSPARC and back to relion. This worked earlier this year but not right now. Upon some inspection, seems CryoSPARC now (v 3.2.0) changed the name of the micrographs when importing. I suspect this is the problem. WHat’s a good way to deal with it?

Here is more details:

Commend I used now that doesn’t work: …/P66/J46/particles_selected.cs …/P66/J46/P66_J46_passthrough_particles_selected.cs --relion2 --micrograph-path CtfFind/job024/ --copy-micrograph-coordinates Extract/job028/

Error is:
raise KeyError(f"None of {missing} are in the columns")
KeyError: ‘None of [None] are in the columns’

Similar commend that worked before and still works now: …/P54/J17/particles_selected.cs …/P54/J17/passthrough_particles_selected.cs --relion2 --micrograph-path Select/job006/ --copy-micrograph-coordinates Extract/job017/

This job was run earlier and I noticed that the format of the passthrough file has changed from passthrough_particles_selected.cs to P66_J46_passthrough_particles_selected.cs.

The most import change seem happened at importing. When I go to the import directory of the import job. previous job has this:
FoilHole_12443267_Data_10486137_10486139_20201112_082930_aligned_DW.mrcs -> /mnt/fei_wynton/WT_Clodronate_SLAC_11092020/relion/Extract/fei5_2_bin4/micrographs/Fei5_2/FoilHole_12443267_Data_10486137_10486139_20201112_082930_aligned_DW.mrcs

And new job has this:
000827143882849198293_Fei33_4_data-hgsnat_964_0007.mrcs -> /mnt/fei_wynton/HGSNAT_Krios2_05202021/relion/Extract/FromMovie_Bin4/MotionCorr/all/movie/Fei33_4_data-hgsnat_964_0007.mrcs

000827143882849198293_Fei33_4_data-hgsnat_964_0007.mrcs is not a micrograph name I have. Looks to me CryoSPARC created this new name. Do I need to add another passthrough file? which one should I add?

If my diagnostic is wrong, what’s the problem I’m having now?


Hi fei, I avoided updating due to this issue but perhaps this is the fix.

Hi, user123,

Thanks a lot! looks like this is probably the cause. I’ll definitely try to work around.
I hope they got this fixed soon!