Convert .cs file to star in 2D selection job

I use the to convert the selected 2D class particle to star file. The command is show as below /mnt/DATA1/cryosparc_database/project/Wei/P4/J54/particles_selected.cs --passthrough /mnt/DATA1/cryosparc_database/project/Wei/P4/J54/passthrough_particles_selected.cs ./

However is show the error error: unrecognized arguments: --passthrough

Hi Robin - the latest version of does not take the passthrough flag. You can just add the passthrough cs file, if needed, as an additional cs file without this flag, e.g: my_particles.cs pasthrough_particles.cs

Thank you Oli, I try it as the command /mnt/DATA1/cryosparc_database/project/Wei/P4/J54/particles_selected.cs /mnt/DATA1/cryosparc_database/project/Wei/P4/J54/passthrough_particles_selected.cs ./

and found the error

Columns must be same length as key
A passthrough file may be required (check inside the cryoSPARC 2+ job directory)

it looks like the particle number is different in two cs file.
however the the job folder there is only two passthroug cs file, passthrough_particles_excluded.cs passthrough_particles_selected.cs. It looks strange.

Ignore the “passthrough may be required” message - it is a generic error message persisting from an older version of the script as I understand it (@DanielAsarnow is this right?).

But yes, it seems like these two files are not compatible - I’ve run into this as well with certain job types. which job types were they from? Does running just on the particles_selected.cs work?


It is a 2D select job, and I try to run the just on the particles_selected.cs and is works and get the list of particle name.

Yes - I haven’t had any luck using on the output of a select2D job either, I get the same error.


Hi, I have particles which were extracted in Relion and imported in cryoSPARC. When I tried to export .cs file from Select2D job to .star using the following command: particles_selected.cs passthrough_particles_selected.cs

but got following error: error: unrecognized arguments:

Thank you for any suggestions.

@yxlui 1) use --loglevel debug and post the entire stacktrace. 2) Make sure you have Python 3 and the latest master branch of pyem with all dependencies, and that --help prints all options successfully.