Connect exposures to imported particles

I usually connect my exposures when I re-import particles that have been classified in another program. In 3.0+ this started failing, because the “source” micrograph file name has characters before the first underscore removed.

Unchecking “Remove leading UID in input micrograph path” does fix the issue, but is this intended behavior? There are no cryoSPARC UIDs in any of the paths, and I had never seen the issue that option was meant to correct.

Thanks for this! I was suddenly running into this exact issue importing particles picked by Warp after upgrading from 2.15 to 3.0.1. Our filenames, generated by Leginon, have many underscores.

Hey @DanielAsarnow,

This is a bug- this option shouldn’t be turned on by default. Thanks for reporting!