Bug in volume tools


If one gives the input and output volume type as mask, but does not set a threshold (e.g. when resampling a mask to a smaller box to use with downsampled particles), the resultant volume looks like a mask in the log, but it is not - it is a map, with small but non zero values in the masked area. This causes artefacts in subsequent local refinement steps.

Either this should be fixed, or the job should fail if mask output is selected but threshold is not set.


EDIT: adding some screenshots of the funky “not-a-mask” that volume tools creates. Looks semi-normal but then completely nuts at one particular threshold. The histogram also doesn’t look like a normal mask.

I think maybe the same issue is sometimes happening internally during local refinement.

I just started a local refinement using inputs that were derived from a non uniform refinement run with downsampled particles, but with full-scale particle input. At the start of the log, it states that it is resampling the mask, and after a couple of iterations I see fine parallel lines in the map which gradually become more prominent. when I look at the mask, it looks similar to the one posted above, with an odd looking histogram.

When I run the same refinement, but with a mask that I have manually resampled, I do not see these artefacts, and the histogram of the refinement mask looks normal.

Hi @olibclarke,

Thanks for reporting. We’ll try to address the volume tools bug in our next release. For now, the job does presume that thresholds are set when masks are used (if not, the resampling is done via Fourier cropping, which does introduce small amounts of ringing, and isn’t intended for masks where it can produce subtle errors like this).

About the refinement masks, the mask isn’t modified each iteration (I assume you’re seeing this on static masking), and the initial mask re-sampling in refinements was recently re-worked in order to avoid any of the ringing that you’re showing – so it makes sense that you only see this when the mask itself starts out with some ringing already present. In any case I agree, volume tools should also be modified to use the appropriate resampling method for volumes vs. masks.


1 Like

Thanks @mmclean, looking forward to the new release!

This bug has been fixed in the v3.3.1 release (December 1, 2021). Thanks!

1 Like