AttributeError: 'NoneType' object has no attribute 'get_items'

Hello everyone,

We have imported one job (Local Resolution Estimation) from an old project and an old instance onto a newly installed, user-based fresh instance.
Once imported, we want to run it again by Clear Job, then Actions → Queue Job on XXX. We run CS on a SLURM cluster.

All the job data seems to be there.
The folder is writable by the cryosparc instance owner, and the cryosparc owner can also launch jobs in SLURM.
We didn’t import the whole original project due to the size of it (thousand of jobs :sweat_smile:) - and it is not clear we want all the information available.

Unfortunately the job is queued but crashes immediately after starting, and we are not able to know why.

The error looks like this:

[CPU: 511.4 MB]  Traceback (most recent call last):
  File "cryosparc_worker/cryosparc_compute/", line 84, in
  File "cryosparc_worker/cryosparc_compute/jobs/local_resolution/", line 620, in
AttributeError: 'NoneType' object has no attribute 'get_items'

We’ve tried different queues, the last cryosparc (3.3.2, and 3.3.2 patched) and also different older versions (3.2.0, 3.1.0) with the same result.
Other CS instances (for other users) seems to run fine, so we think it’s not SLURM.

Are we missing something?
Do you know how to run this imported old job?
Thank you in advance for your feedback!

You are probably missing the job’s inputs. Input consolidation unfortunately is not included in the job export routine. As a workaround, may I suggest exporting/importing the job(s) immediately upstream to Local Resolution Estimation from the old instance.

@wtempel, thanks for the quick answer, we’ll see how much we can isolate that job.
In any case, I’m sure we are not speaking about importing the whole project! :grin:.
For the records, I will try to update the post as soon as we manage…