Assertion error in Topaz train when using denoised micrographs

Hey everyone,
I have performed Topaz denoise on my micrographs in order to use the output for Topaz train, but I keep getting this error:

Traceback (most recent call last):
File “cryosparc_master/cryosparc_compute/”, line 95, in
File “/software/presto/e/9.6/software/cryosparc/4.4.1-foss-2021a-CUDA-11.3.1/cryosparc_worker/cryosparc_compute/jobs/topaz/”, line 150, in run_topaz_wrapper_train
assert os.path.isfile(abs_mrc_path), (
AssertionError: Could not find micrograph “” in “/path/to/my/cryosparc/directory”; please check that the micrographs.micrograph_blob_denoised input slot is connected and that the parent job exists and has not been cleared.

Even though the Denoise job folder is not empty and the parent job does exist.
How can I fix it?

Please can you share additional information:

  1. output of the command
    cryosparcm cli "get_job('P44', 'J553', 'version', 'job_type', 'instance_information', 'params_spec', 'input_slot_groups')"
    where P44 and J553 have been replaced with the Topaz Train job’s actual project and job IDs, respectively.
  2. confirmation that the specific micrograph referred to by is readable and intact. The file may be missing even if

Thank you for your response. I couldn’t run the command cryosparcm beacause I don’t know where the cryosparc_master was. when I looked for it, I got permission denied so I had to try in a different way.
What worked eventually was setting the parameter: use denoised micrographs to false (I don’t know why it worked or why it did not work before).



taken together suggest that denoised micrographs were absent from the expected location or otherwise unavailable.