After upgrade to 4.4 -- No match for doseweights

I’ve just run the upgrade from 4.3 to 4.4. Now when I run the patch motion correction job that I always test with, I get this error:

Traceback (most recent call last):
  File "cryosparc_master/cryosparc_compute/", line 95, in
  File "cryosparc_master/cryosparc_compute/jobs/motioncorrection/", line 54, in
  File "/projects/MOLBIO/local/cryosparc-della/cryosparc_worker/cryosparc_compute/jobs/", line 657, in load_input_group
    input_group = com.query(job['input_slot_groups'], lambda g : g['name'] == input_group_name, error='No match for %s in job %s' % (input_group_name, job['uid']))
  File "/projects/MOLBIO/local/cryosparc-della/cryosparc_worker/cryosparc_compute/jobs/", line 714, in query
    assert res != default, error
AssertionError: No match for doseweights in job J24

Does Patch Motion Correction fail even if the job is built from scratch, as opposed to cloned from a job originally built in CryoSPARC v < 4.4?

It only fails if I clone a job from 4.3. If I make a new job, it works.

Thanks for bringing this to our attention - it is a bug. Creating a fresh job, rather than cloning and old one, should serve as a workaround for anyone experiencing this.
– Harris

Any chance this bug will be solved in future updates? We cleaned up some jobs from older projects and now that we wanted to re-run a few jobs it has become quite an issue…


1 Like

Yes, we’re aware of this issue and intend to fix it in a future version.

Hi, Thanks for the confirmation. Sorry to get back bothering about this, but:

Is there any workaround that makes re-running the same jobs feasible? The problem is that making fresh jobs does work, but trying to reassign the old particles to the “new” micrographs seems to still give an issue, which basically means I would need to do again all the processing for these datasets… and I have not found any good way of doing this. Or maybe I am missing some option that should make this work.

Any help or default working pipeline would be highly appreciated.


@are, sadly there isn’t a “good” workaround, but we have fixed this issue and the fix will be released pretty soon.

1 Like

@are, this is fixed in CryoSPARC v4.5, released today.


Amazing! Thank you :slight_smile: