Access cryoSPARC Live

Hello, I cannot access the cryoSPARC Live web interface.

Doing cryosparcm status I see it is running

liveapp RUNNING pid 48238, uptime 0:43:03

and the port is the default


so cryoSPARC Live should be at localhost:39006 but it does not work.

Thank you

How long has it been since you’ve started cryosparc? Assuming the live webapp worked before (no firewall rules blocking the port) I would first try to restart the live webapp with ‘cryosparcm restart liveapp’.

If you still can’t access the live app i would try to check it by using curl from the cryosparc master: ‘curl http://localhost:39006’ this should return some html if the live app is running properly.

1 Like

I installed cryoSPARC yesterday in that computer, so live webapp has not worked before.
I restarted the live webapp and still can’t access. Checking using curl returns some html.

If your able to get html returned on curl locally then it would point to something blocking the connection to port 39006 from your system to the cryosparc master; is the firewall enabled on the cryosparc master? has a new rule been created for the live port?

Yes, it was because of the firewall, thank you, now I am able to access cryoSPARC live.