2D classification in version 4.2.0-beta issues

I have tried the new version 4.2.0-beta and encountered issues with 2D classification not being able to work properly. I’ve tried both a small apof benchmark dataset and a previously working dataset, with similar end results where the 2D classes seemed unrecognizable (or blank) afterwards.

We also had some issues with 2D classes all of a sudden turning blank.
Some of these issues could be resolved by refreshing the cache on the computing nodes (i.e. delete and let cryosparc re-cache); other jobs have given blank classes even after recaching, however… granted, the blob pick behind the particles was really bad, but it is the first time I really see fully blank, large classes.

I am here with the same report Class2D seems broken in 4.2:
Class2D in 4.2:

same Class2D in 4.1.2:

@chen12 @Andrea @osinskit
Thanks for reporting this issue, which we were able to reproduce on CryoSPARC v4.2 when a 2D classification job uses more than a single GPU. Until we release a fix, we recommend running 2D classification on a single GPU. Please let us know if running on a single GPU resolves the issue for your 2D classification tasks.

1 Like

Thanks. Running with a single GPU seemed to have addressed the issue…


Indeed single GPU works on the same dataset.


Thank you, @wtempel , single GPU addressed the issue.

1 Like

Same problem same solution

@chen12 @Andrea @osinskit @MHB

Another option: Patch 230302 includes a fix for this issue.


Hi @wtempel, I’m not sure that this issue is entirely fixed. Under most circumstances 2D works fine for us, but we have noticed that with large particles (800px) we see the same issues reported here - large, apparently empty/blank 2D classes, mixed in with good 2D classes, and the “blank” classes contain good particles.

This happens in 4.2.2, and happens when using either a single or multiple GPUs for the job. The same particles downsampled to 300px give normal results.


Thanks for the report @olibclarke. Please can you email us the job reports for the “normal” 300px 2D classification job and the most similar 800px where the problem occurs.

1 Like

Sent via DM, thanks @wtempel!

Hi @olibclarke,

We haven’t yet identified a clear cause to this issue, and we are unsure if this is just a pathology of 2D classification on this data, or if this is indicative of a bug. I believe the data we have are particles at a box size of 150px, so we aren’t able to reproduce the strange results at the 800px box size.

If anyone notices similar behaviour, please let us know. Specifically, we’re interested in the case where 2D classes containing large numbers of particles appear nearly empty, and where this is only occurring as of v4.2.0+ and didn’t occur on previous versions.

Thanks all,