Csparc2star output Relion compatibility

use a for loop or similar - e.g. make a list of the mrc file names in a text file, and then:

cat list.txt | while read line; do ln -s /path/to/dir/{$line} .; done

many other ways to do this too


1 Like

I am getting the same error, I am afraid I did not made all the symlinks required. I have made a folder called relion, then created into this folder all J folders containing the mrc files, and symlinked the mrc files into those folders. Then changed the names to .mrcs and updated the star file with the mrcs extensions.

[marino_j@merlin-l-01 relion]$ ls
Class3D cryosparc_P1_J1074_009_volume_mask_refine.mrc Import J379 J836 J840 J842 Trash
cryosparc_P1_J1074_009_volume_map.mrc default_pipeline.star InitialModel J419 J838 J841 particles_1074.star
[marino_j@merlin-l-01 relion]$ in: /var/tmp/bliven_s/relion-3.1.2/src/src/image.h, line 264
Cannot read file J379/extract/FoilHole_16656806_Data_16639377_16639379_20200120_042449_fractions_patch_aligned_doseweighted_particles.mrcs It does not exist
=== Backtrace ===
relion_display(_ZN11RelionErrorC2ERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEES7_l+0x63) [0x4a0e23]
relion_display(_ZN13fImageHandler8openFileERK8FileNamei+0xbf9) [0x4e5259]
relion_display(_ZN5ImageIdE4readERK8FileNameblbb+0xce) [0x59812e]
relion_display(_ZN17basisViewerWindow10fillCanvasEiR13MetaDataTableP16ObservationModel8EMDLabelS4_bbdddddilddbPS0_ibbS5_b8FileNameS6_i+0x12d) [0x5c504d]
relion_display(_ZN9Displayer3runEv+0xb75) [0x5c6fe5]
relion_display(main+0x73) [0x496f63]
/usr/lib64/libc.so.6(__libc_start_main+0xf5) [0x7f49b09b2555]
relion_display() [0x499c3e]

Cannot read file J379/extract/FoilHole_16656806_Data_16639377_16639379_20200120_042449_fractions_patch_aligned_doseweighted_particles.mrcs It does not exist

And here is a screenshot of the particles.star file that I have imported in relion:


_rlnVoltage #1
_rlnSphericalAberration #2
_rlnAmplitudeContrast #3
_rlnOpticsGroup #4
_rlnImageSize #5
_rlnImagePixelSize #6
_rlnImageDimensionality #7
300.000000 2.700000 0.100000 4 300 1.080000 2
300.000000 2.700000 0.100000 8 300 1.080000 2
300.000000 2.700000 0.100000 11 300 1.080000 2
300.000000 2.700000 0.100000 12 300 1.080000 2


_rlnImageName #1
_rlnAngleRot #2
_rlnAngleTilt #3
_rlnAnglePsi #4
_rlnOriginXAngst #5
_rlnOriginYAngst #6
_rlnDefocusU #7
_rlnDefocusV #8
_rlnDefocusAngle #9
_rlnPhaseShift #10
_rlnCtfBfactor #11
_rlnOpticsGroup #12
_rlnRandomSubset #13
_rlnClassNumber #14
000042@J379/extract/FoilHole_16656806_Data_16639377_16639379_20200120_042449_fractions_patch_aligned_doseweighted_particles.mrcs 98.746719 93.038704 108.257896 -12.909376 -16.149376 10666.175781 10430.408203 -44.040096 0.000000 0.000000 4 2 1
000068@J379/extract/FoilHole_16656803_Data_16639473_16639475_20200120_042349_fractions_patch_aligned_doseweighted_particles.mrcs -22.327885 92.721878 120.375702 3.189375 -15.339376 7508.473633 7276.133301 -40.371174 0.000000 0.000000 4 1 1
000081@J379/extract/FoilHole_16656803_Data_16639473_16639475_20200120_042349_fractions_patch_aligned_doseweighted_particles.mrcs -84.153366 96.233147 -10.282413 -20.705626 28.400626 7419.894531 7187.554199 -40.371174 0.000000 0.000000 4 2 1
000099@J379/extract/FoilHole_16656803_Data_16639473_16639475_20200120_042349_fractions_patch_aligned_doseweighted_particles.mrcs 10.460021 97.723030 13.037312 13.719376 -4.910625 7505.092773 7272.752441 -40.371174 0.000000 0.000000 4 1 1

Can someone help me to understand what part did I miss to let relion find the .mrcs files ? I apologize in advance if I have missed this info in any other discussion on this forum !! Thanks

Hi Jacopo, if you execute ls -lrt J379/extract/FoilHole_16656806_Data_16639377_16639379_20200120_042449_fractions_patch_aligned_doseweighted_particles.mrcs from the directory where you run relion, what do you see?

@olibclarke Hi, and thanks for having had a look at my question. Indeed, the problem was with the way the files were linked. I then got another instruction from our cluster admins, and then it worked. Many thanks again and sorry for having disturbed you for these type of trivial problems that have not much to do with image processing and cryo-EM ! I hope I have more interesting news to share once I have made a comparison between CS and 3D-classification in Relion. Cheers

1 Like

Hi @marino-j
I got exactly the same error. Could you please let me know which instructions did you got?
Thanks a lot!

@Smona try with this command

find SRC_DIR -name “PATTERN” | xargs ln -s -t TARGET_DIR

where SCR_DIR is the path to your files, “PATTERN” is for example “*.mrc”, and TARGET_DIR is the directory where to link all your files

1 Like

Thanks a lot @marino-j it worked!

Hi Bue,
Can you please shar the sed command you used to change the .mrc by .mrcs in your star file? For some reason I execute the sed command but when I look at the file not all the lines can be modified.

I just realized that It should be performed using double quotes "

Hi @alfredo07!

It is already ages ago since I solved this problem …
Did it work? Did you say you had to use double quotes like this?

sed -i "s/@>/@/g" from_csparc.star

I think this depends on which shell or unix flavor you use.

Hi @Bue
Yes, exactly. I had to use it like that and also create all the sym links and so on. Finally worked.
Many thanks!

Hi @marino-j,

Do you know what the problem was that this command helped fix? I’m having a similar issue and it’s not related to the “>” in the star file, I’m thinking my issue is similar to what you were experiencing. I’m just trying to figure out what exactly the problem was to try and avoid in the future.


Hi, when I asked our IT, they told me that the other command would not work because it generated more than 100 MB, which is too big of a memory request for a command to be executed. So that other command avoided such memory demand:

find SRC_DIR -name “PATTERN” | xargs ln -s -t TARGET_DIR