When I launch the job, error shows up. Has anyone met same problems and fixed it?

Dear all;
When I launch the job, error was shown up as below;

(Visualized window)
Launched job YLtFKLMeoAdreQoL6
Traceback (most recent call last):
File “/home/szhu/cryosparc/cryosparc-compute/sparcjob.py”, line 59, in
link.enable(job_id = job_id)
File “/home/szhu/cryosparc/cryosparc-compute/sparc/link.py”, line 31, in enable
hardware_id_valid, hardware_id = get_hardware_id()
File “”, line 50, in get_hardware_id
File “/home/szhu/cryosparc/anaconda2/lib/python2.7/subprocess.py”, line 212, in check_output
process = Popen(stdout=PIPE, *popenargs, **kwargs)
File “/home/szhu/cryosparc/anaconda2/lib/python2.7/subprocess.py”, line 390, in init
errread, errwrite)
File “/home/szhu/cryosparc/anaconda2/lib/python2.7/subprocess.py”, line 1024, in _execute_child
raise child_exception
OSError: [Errno 2] No such file or directory


Hi Victor,

had the same problem - try restarting the cSPARC, it worked afterwards.



Hi Simonas,

Thanks for your reply.
I tried several times, terminated cryosparc and restarted. Furthermore, I removed the dataset.
These actions did not work. Still same error. In additional to restart cryosparc, Would you have other suggestions.
Again, much appreciated.


Hi Victor,
What OS are you running on? Can you please run the following to see if the ifconfig utility is available?

which ifconfig


Hi Apunjani,

Thanks a lot. You are right. I found my sbin was not in my path.
Basically, ifconfig should be in directory of /sbin. And what I did is just adding the /sbin to my /.bashrc file.
Now it is working. This small mistake has disturbed me for a while. I hope this one is also helpful for freshers including me.
Thanks a lot Apunjani and other members in this community.