Refinement error following importing from relion

Hi All,

I am running into a refinement error following importing particles from relion. The data was initially processed in cryoSPARC, but then I exported particles into relion in order to try ctf refinement. Following that, I imported the particles back into cryoSPARC.

During the import step (J1112), I provided two input parameters:

  1. star file from relion (which was modified to convert *local_aligned.mrcs lines back to local_aligned.mrc)
  2. a path to the original local motion job directory (J776) where the original particle stacks reside

The import job appears to be working because the correct number of particles were imported, I can see the low-pass filtered particle images, and the correct microscope params were read in from the star file. Inside the import particle job directoy, there is a subdirectory with symbolic links to the original mrc files from J776 (the local_motion job).

Afterwards, when I try to perform NU-refinement with the imported particles, I encounter the following error:

Traceback (most recent call last):
File “cryosparc2_worker/cryosparc2_compute/”, line 78, in
File “cryosparc2_worker/cryosparc2_compute/jobs/nonuniform_refine/”, line 97, in
File “cryosparc2_compute/”, line 65, in read_blobs
u_blob_paths = cache.download_and_return_cache_paths(u_rel_paths)
File “cryosparc2_compute/jobs/”, line 125, in download_and_return_cache_paths
hits, sizes_mb = check_files(proj_dir_abs, rel_paths, ssd_cache_path, keys)
File “cryosparc2_compute/jobs/”, line 211, in check_files
size_mb = os.path.getsize(bulk_path) / 1024.02**
File “/home/cryosparc2/cryosparc2_worker/deps/anaconda/lib/python2.7/”, line 57, in getsize
return os.stat(filename).st_size
OSError: [Errno 2] No such file or directory: '/home/cryosparc2/cryosparc_projects2/yazan/newproject/P51/J1112/imported/FoilHole_148052_Data_30141907_30141908_20190201_1329_Fractions_particles_local_aligned.mrc’

I thought this error might be related to the cache on our SSD, so I deleted the project directory in /home/cryosparc2/instance*/projects and tried to re-run the project.

I keep getting the same error, and strangely enough at the beginning of the run, the job output shows

Loading a ParticleStack with 67924 items…
SSD cache : cache successfuly synced in_use
SSD cache : cache successfuly synced, found 67303.69MB of files on SSD.
SSD cache : cache successfuly requested to check 6019 files.

which suggests it is finding the particles in its cache, even though they were deleted and there is no sign of my project files in the cache.

Any help would be appreciated. Am I missing something in my troubleshooting?



Just discovered my error: the particle stacks are on the master cryosparc node and I was trying to run the refinement on a worker node. The symbolic links inside the import job point to a folder on a drive mounted on the master node, and the worker node had no way of getting to them.