Poor CTF fit using patch CTF estimation in cryoSPARC v2.13.2



Hello everyone,

I have a question about the CTF fits that I have been getting using patch CTF estimation in cryoSPARC version 2.13.2. As shown in the screenshot below I am getting what appear to be acceptable fits until around 7Å. However, at higher resolution it does not appear to fit the CTF despite the presence of signal. I have collected a similar sample (same protein and grid type with similar ice) on another microscope without CTF issues. The sample was collected on C-flat grids on a Titan Krios with a Falcon III detector. I have double checked the pixel size, accelerating voltage, and Cs values.

Any suggestions on avoiding this situation in the future and/or improving the CTF fit for this dataset would be greatly appreciated.

Many thanks in advance,


Hi @Andrew,

Was this data tilted, or was it phase plate data?
When you see the “3D” plot from patch CTF, does it show a large variation in the defocus landscape of the micrograph?

Can you try the following (this will force the job to assume the micrograph is flat):

  1. clone the patch CTF job
  2. set the “Number of movies to process” to 10 or so just for testing
  3. set the “Override Knots X” and “Override Knots Y” both to 1 (there are advanced params)


Hi @apunjani,

Thanks for your reply. This collection is not from a tilted or phase plate data collection. Here is the 3D plot that goes with the patch ctf fit image that I posted previously:

I just tried the job you suggested where the micrograph is assumed to be flat. As you can see below I am still getting a similar issue.

Do you have any other suggestions?

Many thanks for you help.


Hi @Andrew,
This is interesting… based on the 1D plots, there seems to be signal that is creating coherent Thon rings to quite high resolution. Can you try changing the “Minimum resolution (A)” parameter to something like 10A or 8A ? this will cause the fit to only look at the high resolution information.

Can you also provide a few example images of the micrographs? It may be that you have ice/aggregates/carbon edges that are at a different height (defocus) on average than the particles… this would cause the low-res CTF to not match the high-res CTF.


Thanks for your reply @apunjani,

I tried your suggestion of setting the resolution used to fit the CTF from 4-10A. Here is a representative CTF fit from this job:

From this it appears there is little signal here in contrast to the previous micrographs.

Also, here are a few micrographs and their CTF fits using the default parameters:
Example 1:

Example 2:



Hi @Andrew, thanks for sharing.
Unfortunately based on this result, I’m not sure what to suggest next… the 4-10A result seems quite poor, and maybe something has gone wrong there… would you be open to share a few of these troublesome micrographs with our team (confidentially) so we can debug?