Job Failure after cloning 2D job

open

#1

Hello all,

I am working on 2D classification with around 50,000 particles and the following non-default settings:
Window dataset: off
Number of 2D classes: 150
Max resolution: 10
Number of EM iterations: 25
Batchsize: 200
Enforce non-neg: on
use clamp-solvent: on

However, when I begin to run jobs that had worked previously, the following error appears:

Start of iteration 0

Traceback (most recent call last):
  File "cryosparc2_compute/jobs/runcommon.py", line 747, in run_with_except_hook
    run_old(*args, **kw)
  File "cryosparc2_worker/cryosparc2_compute/engine/cuda_core.py", line 101, in cryosparc2_compute.engine.cuda_core.GPUThread.run
  File "cryosparc2_worker/cryosparc2_compute/engine/cuda_core.py", line 102, in cryosparc2_compute.engine.cuda_core.GPUThread.run
  File "cryosparc2_worker/cryosparc2_compute/engine/engine.py", line 987, in cryosparc2_compute.engine.engine.process.work
  File "cryosparc2_worker/cryosparc2_compute/engine/engine.py", line 88, in cryosparc2_compute.engine.engine.EngineThread.load_image_data_gpu
ValueError: could not broadcast input array from shape (62,62) into shape (124,124)

I don’t believe there is something wrong with the parameters or data set because this also happens when I clone a 2d classification job that worked previously. Does anyone have any ideas to fix this problem?


#2

HI @ajstanley,

The issue seems to be related to the particle sizes. Could you clarify the following:

  • What is the original size of the particles?
  • Were the particles downsampled/binned/resized at any point?
  • What job did the particles come from?

Thanks,
Ali


#3

The original box size of the particles was 250. They were then rescaled to 124 and then 62. Everything before the 2D classification was done in Relion and imported to cryoSPARC (import micrograph stacks).

I have separate projects for these sizes (250, 124, 62) with imports for each scale. However, I think you are right in that the rescaling may be the issue, as only the 62 rescaled 2D classification is currently working.


#4

Hi @ajstanley,

From the traceback you pasted in the initial message, it seems like there was a mixup at some point between the 62 pix and 124 pix particle stacks. cryoSPARC is expecting 124x124 images, but it receives 62x62 images (or vice versa). Could you double check that the sizes in the star files you imported are all correct?

In general, assuming you don’t have a specific reason for picking 62 and 124 as box sizes, I would recommend using 64 and 128 as box sizes in powers of 2 are typically faster during Fourier transforms.

Best,
Ali