Hardware not registered error


I just tried to upload a new dataset into cryosparc using our labs dedicated machine. I’ve used cryosparc on it before (with good results!) However this time when I define all my variables and hit ‘launch’ it says ‘hardware not registered’. I think we may be having some licensing issues?

A single license is allowed per lab. You probably have another computer in the lab that is running cryoSPARC. There are instructions for disabling a license on one machine so that another can use the license.

No, we have a single dedicated computer for our laboratory. We have tried to disable and re-enable the license on our dedicated machine, but we still get the ‘hardware not registered’ error…

Hi @ekellogg, just confirming that this was sorted out and everything is working okay?

Hi Ali,

yes thank you so much! We tried what you suggested and we’re back to normal. Thank you!


Hi all,

I’m glad I stumbled across this post. I too have been having issues with the licencing of the hardware.

To be clear, I have the same problem as stated above. I’ve installed cryosparc on only one machine. However, I have to deregister the hardward before launching almost every second job (making it impossible for non-admin users).

I had installed cryosparc once, then we decided to change our system and resultantly I deleted and reinstalled cryosparc. This is when the issues started.

Any help would be greatly appreciated,

Hi Charles–

I wanted to ask if you got this sorted out-- I am having the exact same problem.


Hi Melody,

No I have yet to hear back from anyone regarding this issue. I’ve not managed to solve it either. I’m hoping that in the v2 release it may be resolved…


Hi Charles,

Thanks! Fingers crossed for the new version having a fix-- I’ll let you know if I figure out anything in the meantime.


Hi Liz, I am having a similar issue. What worked for you? In your Aug 17 message, you said that disabling and re-enabling the license did not work.